Project

General

Profile

Bug #33980

New OS created due to facts mismatch for operatingsystem for RHSM, Puppet and Ansible

Added by Marek Hulán 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2025437

Description of problem:
- When rhsm or puppet is sending facts for the OS it updates the facts to the name of "RedHat".
- If an Ansible role is later run it uses "RedHatEnterprise" (RHEL 8) or "RedHatEnterpriseServer" (RHEL 7).

Version-Release number of selected component (if applicable):
- Satellite 6.10.1

How reproducible:
- The OS is created automatically in Hosts => Operating Systems
- To check for the name go into each OS and check the Name field

Steps to Reproduce:
1. Register RHEl 8 client to Satellite
2. Run "subscription-manager facts --update"
3. The OS should be set to an OS which Name is "RedHat"
4. Run any playbook on the client that gathers facts
5. The OS for the client is updated to an OS that has "RedHatEnterprise" in its name

Actual Results:
If the option "ignore_facts_for_operating system" is set to "no" (default) the OS for a client is updated
to the last fact that was reported. This leads to the OS for a client to constantly switch between the
different OS and double the OS entries created than required.

Expected Results:
The Ansible reported fact for OS should be matched to the one that is reported by RHSM or Puppet.

Additional info:
- The fact matcher for Ansible seems to use ansible_lsb.id which delivers different values'


Related issues

Copied to Foreman - Bug #33981: New OS created due to facts mismatch for operatingsystem for RHSM, Puppet and AnsibleClosed

History

#1 Updated by Marek Hulán 7 months ago

  • Copied to Bug #33981: New OS created due to facts mismatch for operatingsystem for RHSM, Puppet and Ansible added

#2 Updated by The Foreman Bot 7 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_ansible/pull/489 added

#3 Updated by Ondřej Ezr 5 months ago

  • Status changed from Ready For Testing to Closed
  • Subject changed from New OS created due to facts mismatch for operatingsystem for RHSM, Puppet and Ansible to New OS created due to facts mismatch for operatingsystem for RHSM, Puppet and Ansible
  • Fixed in Releases foreman_ansible-6.4.2 added

Also available in: Atom PDF