Project

General

Profile

Bug #34245

Uploading python packages broken in UI and CLI

Added by Ryan Verdile 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

In CLI:

  • Gives error: undefined method `pulp3_api' for nil:NilClass

In UI:

  • Gives successful upload message, but "uploads" the wrong package.

Related issues

Is duplicate of Katello - Bug #34202: upload-content results in wrong RPM being added to productClosed

Associated revisions

Revision d5ac4b66 (diff)
Added by Justin Sherrill 3 months ago

Fixes #34178,#34245 - add generic repository testing

and enable an ostree test

History

#1 Updated by Chris Roberts 4 months ago

  • Triaged changed from No to Yes

#2 Updated by Ryan Verdile 4 months ago

  • Is duplicate of Bug #34202: upload-content results in wrong RPM being added to product added

#3 Updated by Ryan Verdile 4 months ago

  • Status changed from New to Closed

#4 Updated by The Foreman Bot 4 months ago

  • Assignee set to Justin Sherrill
  • Pull request https://github.com/Katello/katello/pull/9867 added

#5 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.5.0 added

#6 Updated by Chris Roberts 3 months ago

  • Target version changed from Katello 4.3.1 to Katello 4.4.0

#7 Updated by Ian Ballou 3 months ago

  • Category set to Repositories

Also available in: Atom PDF