Project

General

Profile

Bug #34250

Grammatical errors with Insecure help text at Host Registration

Added by Leos Stejskal 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host registration
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Steps to Reproduce:
1. Go to Hosts > Register Host
2. Click on the "?" next to the "Insecure" check box

Actual results:
"If the target machine does not trust the host SSL certificate, the initial connection could be subject to Man in the middle attack. If you accept the risk and do not require the server authenticity to be verified, you can enable insecure argument for the initial curl. Note that all subsequent communication is then properly secured, because the initial request deploys the SSL certificate for the rest of the registration process."

Expected results:
"If the target machine does not trust the host SSL certificate, the initial connection could be subject to a man-in-the-middle attack. If you accept the risk and do not require the server authenticity to be verified, you can enable insecure argument for the initial curl. Note that all subsequent communication is then properly secured, because the initial request deploys the SSL certificate for the rest of the registration process."

Additional notes:
I just added "a man-in-the-middle attack" to make the text more readable and consistent.

Associated revisions

Revision c429b5b4 (diff)
Added by Leos Stejskal 11 months ago

Fixes #34250 - Insecure help text at Host Registration

History

#1 Updated by Leos Stejskal 11 months ago

  • Assignee set to Leos Stejskal
  • Description updated (diff)
  • Subject changed from Grammatical errors with Insecure help text at Host Registration to Grammatical errors with Insecure help text at Host Registration

#2 Updated by Leos Stejskal 11 months ago

  • Triaged changed from No to Yes
  • Category set to Host registration

#3 Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9026 added

#4 Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 3.2.0 added

#5 Updated by Leos Stejskal 11 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Ondřej Ezr 10 months ago

  • Fixed in Releases 3.1.1 added

Also available in: Atom PDF