Project

General

Profile

Bug #34262

Can't install ruby-smart-proxy-salt-core from packages on Debian buster

Added by Dirk Heinrichs 4 months ago. Updated 4 months ago.

Status:
New
Priority:
High
Assignee:
-
Category:
Smart Proxy
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When I try to install Salt support on a working Foreman 3.1 installation installed from packages on Debian buster, I get the following error:

# apt-get install ruby-foreman-salt ruby-smart-proxy-salt ruby-smart-proxy-salt-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ruby-smart-proxy-salt-core : Depends: ruby-foreman-remote-execution-core (>= 0.1.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

In fact, the package ruby-foreman-remote-execution-core doesn't seem to exist.

History

#1 Updated by Dirk Heinrichs 4 months ago

The problem was actually found in 13.2.4, but that's not select-able.

Also available in: Atom PDF