Project

General

Profile

Bug #34299

upgrade fails during db:seed with ActiveRecord::RecordNotDestroyed: Failed to destroy the record

Added by Justin Sherrill 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Upgrade from Katello 4.1 to 4.3 fails during db:seed with ActiveRecord::RecordNotDestroyed: Failed to destroy the record

Empty satellite was used.

How reproducible:
100%

Steps to Reproduce:
1. Have a empty and registered foreman/katello 4.1
2. Upgrade to 4.3 directly

  1. satellite-maintain upgrade run --target-version 7.0 -w repositories-validate,repositories-setup -y
    ...

Running Migration scripts to Satellite 7.0 ================================================================================
Setup repositories: [SKIPPED]
--------------------------------------------------------------------------------
Unlock packages: [OK]
--------------------------------------------------------------------------------
Update package(s) : [OK]
--------------------------------------------------------------------------------
Procedures::Installer::Upgrade: [FAIL]
Failed executing LANG=en_US.utf-8 satellite-installer --disable-system-checks, exit status 6:
...

2022-01-20 17:18:28 [ERROR ] [configure] /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: '/usr/sbin/foreman-rake db:seed' returned 1 instead of one of [0]
2022-01-20 17:18:28 [ERROR ] [configure] /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: '/usr/sbin/foreman-rake db:seed' returned 1 instead of one of [0]
...

Scenario [Migration scripts to Satellite 7.0] failed.

The following steps ended up in failing state:

[installer-upgrade]

Actual results:
failed upgrade due to failing db:seed

Expected results:
successful upgrade"


Related issues

Related to Foreman - Bug #30843: seeding fails with 'This template is locked. Please clone it to a new template to customize.'Closed

Associated revisions

Revision f73d7393 (diff)
Added by Justin Sherrill 4 months ago

Fixes #34299 - allow input deletion during seeding

History

#1 Updated by Justin Sherrill 4 months ago

  • Description updated (diff)
  • Subject changed from upgrade fails during db:seed with ActiveRecord::RecordNotDestroyed: Failed to destroy the record to upgrade fails during db:seed with ActiveRecord::RecordNotDestroyed: Failed to destroy the record

#2 Updated by The Foreman Bot 4 months ago

  • Assignee set to Justin Sherrill
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9046 added

#3 Updated by Justin Sherrill 4 months ago

  • Category changed from TFTP to Templates

#4 Updated by Justin Sherrill 4 months ago

  • Related to Bug #30843: seeding fails with 'This template is locked. Please clone it to a new template to customize.' added

#5 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 3.2.0 added

#6 Updated by Justin Sherrill 4 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Ondřej Ezr 4 months ago

  • Fixed in Releases 3.1.1 added

Also available in: Atom PDF