Project

General

Profile

Bug #34364

Error reporting with

Added by Leos Stejskal 6 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Issue
When REX job fails because of unauthorized ssh key, the error output of the template invocation is only this:

1:
Exit status: EXCEPTION

For the actual error users have to search in the proxy log:

2022-02-01T05:37:25  [E] error while initializing command RuntimeError Unable to create directory on remote system /var/tmp/foreman-ssh-cmd-a808e322-ee12-43b1-b163-5cc5cbed5ad3: exit code: 255
 Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).

The error from the proxy log should be in the template invocation detail so users don't have to dig it from the proxy log.


Related issues

Is duplicate of Foreman Remote Execution - Bug #34363: Improve ssh error reportingClosed

History

#1 Updated by Adam Ruzicka 6 months ago

  • Is duplicate of Bug #34363: Improve ssh error reporting added

#2 Updated by Adam Ruzicka 6 months ago

  • Target version deleted (1539)
  • Status changed from New to Duplicate

Also available in: Atom PDF