Project

General

Profile

Bug #34426

Improve Pulp 3 sync timeout configuration

Added by Ian Ballou 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2043144

Description of problem:
After migrating to Pulp 3, Katello fails to sync some repositories with large files and displays the following error:

Request timed out for https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os/repodata/4ae4b0b9f3e8e0ed6007d17625c04e36a3b01ec9-other.xml.gz. Increasing the total_timeout value on the remote might help. (Katello::Errors::Pulp3Error)

Increasing the default sync connection timeout from 300 to 3600 seconds helps in getting repos synced successfully.

Web UI -> Administer -> Settings -> Content tab -> Sync Connection Timeout -> Set 3600

Steps to Reproduce:
1. After the Pulp 3 migration and switchover, sync some RHEL base repos
2.
3.

Actual results:
Sync fails with the above error due to a smaller timeout value.

Expected results:
The default timeout value should be increased so sync will work successfully.

Additional info:

To reproduce, it may be necessary to add a bandwidth limiter with squid.

Associated revisions

Revision 8f3fbb99 (diff)
Added by Ian Ballou 4 months ago

Fixes #34426 - Improve Pulp 3 sync timeout config (#9939)

History

#1 Updated by Ian Ballou 5 months ago

  • Subject changed from After migrating to Pulp 3, Katello fails to sync some repositories with large files with timeout error to Improve Pulp 3 sync timeout configuration

#2 Updated by Justin Sherrill 5 months ago

  • Triaged changed from No to Yes
  • Target version changed from Katello 4.4.0 to Katello 4.3.2

#3 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9939 added

#4 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases Katello 4.5.0 added

#5 Updated by Anonymous 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF