Project

General

Profile

Bug #34445

Katello not supported with Azure Postgresql Service

Added by Anthony Chevalet 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The installer fails with:

```
PG::FeatureNotSupported: ERROR: extension "evr" is not supported by Azure Database for PostgreSQL
DETAIL: Installing the extension "evr" failed, because it is not on the list of extensions supported by Azure Database for PostgreSQL.
HINT: To see the full list of supported extensions run: SELECT * FROM pg_available_extensions;
```

cf https://community.theforeman.org/t/use-managed-postgresdb-instance-after-with-katello-3-16-and-later/20778/5

It looks to be valid for every cloud providers.

History

#1 Updated by Ian Ballou 5 months ago

  • Target version changed from Katello 4.4.0 to Katello 4.5.0

#2 Updated by Jonathon Turel 5 months ago

  • Triaged changed from No to Yes
  • Target version changed from Katello 4.5.0 to Katello Recycle Bin
  • Status changed from New to Rejected

Errata applicability and other areas of Katello depend on this postgres extension, and getting by without it implies a significant effort. Currently there are no plans to take that work on so I'm closing this out.

Also available in: Atom PDF