Project

General

Profile

Feature #34526

Switch Rails version to 6.1

Added by Leos Stejskal 4 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Rails
Target version:
-

Related issues

Related to Foreman - Tracker #28570: Rails 6.1 TrackerNew

Related to foreman-tasks - Bug #34956: Fix breakages caused by rails 6.1 upgradeClosed

Associated revisions

Revision 8c4d848f (diff)
Added by Leos Stejskal 3 months ago

Fixes #34526 - rescue_from JSON params parse errors

Use rescue_from block instead of the CatchJsonParseErrors middleware
See https://github.com/rails/rails/pull/34341

Revision 1cf4147a (diff)
Added by Leos Stejskal about 1 month ago

Fixes #34526 - Switch Rails version to 6.1

Changes overview:
- Set default Rails version to 6.1
- Required dynfow >= 1.6.5
- Cleanup deprecation warnings in config/as_deprecation_whitelist.yaml
- ActiveSupport::ParameterFilter instead of ActionDispatch::Http::ParameterFilter
- model.errors.attribute_names instead of model.errors.keys
- Fixed issue with iterating over the model.errors
- use .add for adding error messages instead of <<
- 'where.not' use NAND instead of NOR [0]

[0] https://github.com/rails/rails/pull/36029

Revision 5b2789c1 (diff)
Added by Evgeni Golov about 1 month ago

Refs #34526 - Update Rails to 6.1.6

History

#1 Updated by Leos Stejskal 4 months ago

#2 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9117 added

#3 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/9157 added

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.3.0 added

#5 Updated by Leos Stejskal 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases 3.4.0 added

#7 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/9231 added

#8 Updated by Adam Ruzicka about 1 month ago

  • Related to Bug #34956: Fix breakages caused by rails 6.1 upgrade added

Also available in: Atom PDF