Project

General

Profile

Bug #34572

Submit button on host form redirects to invalid page

Added by Ondřej Ezr 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Inventory
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2054011

And also found upstream in https://github.com/theforeman/foreman/pull/9047#issuecomment-1039303156

Description of problem:

- Clicking the submit option on the Host Edit page reverts to an invalid host page.

Version-Release number of selected component (if applicable):

- foreman-3.1.1.4-1.el7sat.noarch

How reproducible:

- Always

Steps to Reproduce:

1. Register a host to the Satellite

2. Access the client on the UI

Satellite WebUI: Hosts --> All Hosts --> Select the Host --> Edit

3. Make any change in the page and click Submit or simply click Submit button

Actual results:

- The action reverts to any invalid host page.

- The domain seems to be added to the hostname of the host again.

- The URL is generated as such.

https://satellite.example.com/new/hosts/client.example.com.example.com#/Overview

Expected results:

- The submit action should revert back to the host page successfully.


Related issues

Related to Foreman - Bug #34300: Host form redirect relies on the primary interface being the first interfaceClosed
Related to Foreman - Feature #33484: Add setting for redirecting to the new host details page Closed

Associated revisions

Revision 27ef7780 (diff)
Added by Amir Fefer 2 months ago

Fixes #34572 - fix invalid redirect after host edit

History

#1 Updated by Ondřej Ezr 2 months ago

  • Related to Bug #34300: Host form redirect relies on the primary interface being the first interface added

#2 Updated by Ondřej Ezr 2 months ago

  • Related to Feature #33484: Add setting for redirecting to the new host details page added

#3 Updated by The Foreman Bot 2 months ago

  • Assignee set to Amir Fefer
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9140 added

#4 Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 3.3.0 added

#5 Updated by Amir Fefer 2 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Ondřej Ezr 2 months ago

  • Subject changed from Submit button on host form redirects to invalid page to Submit button on host form redirects to invalid page
  • Fixed in Releases 3.1.3, 3.2.0 added

Also available in: Atom PDF