Project

General

Profile

Bug #34610

"Subscription - Entitlement Report" does not show correct number of subscriptions attached/consumed

Added by Ian Ballou 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1981444

Description of problem:
"Subscription - Entitlement Report" in Katello uses the pool count incorrectly and double counts for hosts that share subscriptions.

Version-Release number of selected component (if applicable):
Katello 3.18 specifically, but really all versions of Katello.

How reproducible:
Always

Steps to Reproduce:
1. Attach the same subscriptions to multiple hosts
2. Generate a report from Monitor -> Report Templats -> "Subscription - Entitlement Report" -> Generate
3. Compare the value in the column "Subscriptions Consumed" with actual number of subscriptions attached to the host

Actual results:
Numbers don't match

Expected results:
Numbers match

Additional info:

This bug is in both the foreman and katello projects since changes need to be made to both repositories.


Related issues

Copied from Katello - Bug #34609: "Subscription - Entitlement Report" does not show correct number of subscriptions attached/consumedClosed

Associated revisions

Revision f438a96d (diff)
Added by Ian Ballou 3 months ago

Fixes #34610 - Entitlement report double counts consumed subs (#9151)

History

#1 Updated by Ian Ballou 4 months ago

  • Copied from Bug #34609: "Subscription - Entitlement Report" does not show correct number of subscriptions attached/consumed added

#2 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9151 added

#3 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.3.0 added

#4 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF