Project

General

Profile

Bug #34631

Incorrect file permissions in /var/lib/pulp/media/... lead to repository sync errors

Added by Ian Ballou 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Procedure
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2064410

Description of problem:

After the Pulp 2 to Pulp 3 migration, upstream users have been reporting failing syncs that seem to be related to incorrect permissions in Pulp's artifacts directory. Thread: https://community.theforeman.org/t/katello-4-3-repo-sync-error-errno1-operation-not-permitted/27262/11

From the report, it seems that something changed in Pulp 3 between Pulpcore 3.14 and 3.16 that suddenly made the incorrect permissions cause sync errors. Users have no issues syncing on Katello with Pulpcore 3.14.

I'm setting this on the Installer component for now because the installer keeps track of other Pulp-related permissions: https://github.com/theforeman/puppet-pulpcore/blob/master/manifests/config.pp

Foreman Maintain is another place where these permissions could be fixed if there is some reason with doing so in the Foreman Installer.

Version-Release number of selected component (if applicable):

Katello 4.3

How reproducible:
The permissions being wrong is likely 100% reproducible.
The repository sync error is unknown right now because the reporting user could sync some repositories.

Steps to Reproduce:
From Grant's comment, to reproduce you would only need to run the switchover to Pulp 3 where the Pulp 3 files are on the same volume as the Pulp 2 ones: https://community.theforeman.org/t/katello-4-3-repo-sync-error-errno1-operation-not-permitted/27262/14

Actual results:
Syncing fails and some files under /var/lib/pulp/media are owned by apache rather than pulp.

Expected results:
Syncing works fine and the files under /var/lib/pulp/media are owned by the pulp user.

Additional info:

Associated revisions

Revision b6ef0a5e (diff)
Added by Ian Ballou 3 months ago

Fixes #34631 - add command & procedure to update pulpcore artifact ownership

History

#1 Updated by Ian Ballou 4 months ago

  • Target version set to 3.1.3
  • Subject changed from Incorrect file permissions in /var/lib/pulp/media/... lead to repository sync errors to Incorrect file permissions in /var/lib/pulp/media/... lead to repository sync errors

This affects Katello 4.3 users, but not 4.2 interestingly.

#2 Updated by Ian Ballou 4 months ago

  • Description updated (diff)

#3 Updated by The Foreman Bot 4 months ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-pulpcore/pull/250 added

#4 Updated by Ian Ballou 4 months ago

  • Target version deleted (3.1.3)
  • Status changed from Ready For Testing to New
  • Category set to Procedure
  • Project changed from Installer to Foreman Maintain
  • Pull request deleted (https://github.com/theforeman/puppet-pulpcore/pull/250)

Switching to Foreman Maintain.

#5 Updated by Ian Ballou 4 months ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/596 added

#6 Updated by Ian Ballou 4 months ago

  • Status changed from New to Ready For Testing

#7 Updated by Ian Ballou 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF