Project

General

Profile

Actions

Bug #34658

closed

Harmonize preseed templates

Added by Bernhard Suttner about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

- Readability
- Static IP Support for iPXE Template

Actions #1

Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Bernhard Suttner
  • Pull request https://github.com/theforeman/foreman/pull/9158 added
Actions #2

Updated by The Foreman Bot about 2 years ago

  • Fixed in Releases 3.3.0 added
Actions #3

Updated by Anonymous about 2 years ago

  • Status changed from Ready For Testing to Closed
Actions #4

Updated by Amit Upadhye almost 2 years ago

  • Category set to Templates
Actions #5

Updated by Tim Eilers over 1 year ago

@Bernhard

I think your PR/commit introduced issues. We are one of the lonely PXElinux (not iPXE) users out there and when using the new templates in Foreman 3.3, we get "malformed ip adress" in the Ubuntu installer.
Our subnet is set to bootmode "static", so your new "preseed_kernel_options" template is setting f.e. "netcfg/get_ipaddress=${netX/ip}" kernel options. It looks like these variables (netX/ip) are somewhat specific to iPXE and are not processed by PXElinux. So the PXElinux just passed that "variable" string through leading to the installer seeing a malformed ip address. Maybe it is redundant anyway, since the preseed template sets the same options.

I am absolutely no specialist in any of the PXEs, so i am writing here to hear your opinion first. Once confirmed, we can look for a solution.

Actions #6

Updated by Bernhard Suttner over 1 year ago

A colleague of mine is already working on it: https://github.com/theforeman/foreman/pull/9281/files
Maybe you can help by some tests, comments and review? Would be very appreciated.

Actions

Also available in: Atom PDF