Project

General

Profile

Bug #34659

Katello bookmark icon should be consistent with Foreman's

Added by Jeremy Lenz 3 months ago. Updated 24 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Right now Foreman uses the correct bookmark icon (white outline) and Katello uses the incorrect one (solid black). I think there were reasons for this, but I can't recall and anyway we should standardize it.

foreman_bookmarks.png View foreman_bookmarks.png 6.51 KB bookmark icon from HW Models page Jeremy Lenz, 03/21/2022 08:20 PM
black_bookmark.png View black_bookmark.png 2.03 KB bookmark icon from Repository sets Jeremy Lenz, 03/21/2022 08:20 PM
Foreman bookmarks Black bookmark

Associated revisions

Revision a65daa6c (diff)
Added by Chris Roberts about 1 month ago

Fixes #34659 - Change Katello bookmark to Foremans (#10123)

History

#1 Updated by Jeremy Lenz 3 months ago

  • Target version set to Katello 4.5.0

#2 Updated by Andrew Dewar 3 months ago

  • Triaged changed from No to Yes

#3 Updated by Andrew Dewar 3 months ago

"I think there were reasons for this"

Indeed!
So, patternfly uses Font Awesome for their icon library. By default (and perhaps by design) only icons built with the "fas" or fa-solid style are supported, and thus why all patternfly components are using using "fas"/solid styled font-awesome icons. The iconography style/library for the "correct bookmark icon (white outline)" mentioned above would use the "far" or fa-regular font awesome library not supported out of the box from Patternfly.

To be consistent with Patternfly (not foreman), the choice was made when initially designing the bookmark functionality to use the iconography as supported by Patternfly. This was approved by design before applying.

#4 Updated by The Foreman Bot about 1 month ago

  • Assignee set to Chris Roberts
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10123 added

#5 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases Katello 4.5.0 added

#6 Updated by Chris Roberts about 1 month ago

  • Status changed from Ready For Testing to Closed

#7 Updated by The Foreman Bot 24 days ago

  • Pull request https://github.com/Katello/katello/pull/10152 added

Also available in: Atom PDF