Project

General

Profile

Bug #34671

UI suddenly shows "Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors" for a smart proxy even if there are no connectivity issue present

Added by Justin Sherrill 3 months ago. Updated 24 days ago.

Status:
Closed
Priority:
Normal
Category:
Foreman Proxy Content
Target version:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2053928

Description of problem:

Overall everything was going fine but suddenly after a failed capsule sync, I found that even if the communication status of the capsule is green and active, a weird Error message pops up in the Infrastructure --> Capsules page for the capsule where I am trying to refresh the features.

Error
Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors

10.74.xxx.yyy is capsule IP.

How reproducible:

Always (after the failed capsule sync)

Steps to Reproduce: [ Not the exact steps but I am documenting the sequence of events that led to this discovery ]

  • Install Satellite + Capsule 7.0
  • Associate Library environment to Capsule server, for content syncing.
  • Enable and sync one or two repos in satellite and let the auto-sync of capsule server completed as well.
  • Go to Satellite UI --> Infrastructure --> Capsules --> <Click open Capsule> , Manually iniiate a complete\optimized sync for capsule and then again hit the action "Cancel Sync".
  • Once the sync task is canceled, click on the "Refresh Features" button of the capsule.

Actual results:

Communication status: Active (Green)

Clicked on "Refresh Features" and then some messages appears on the Top Right corner

In green:

Success
No changes were found when refreshing features from capsule.example.com.

In Red :

Error
Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors

But the Communication status is still Active (Green) and from satellite, I surely can connect to port 443 of capsule via openssl or curl or nc command.

The hammer command shows, the following tasks.

  1. hammer task list --search "label ~ Capsule and result != success"
    -------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|--------------|-------|---------------------------------------------------------------------------------
    ID | ACTION | STATE | RESULT | STARTED AT | ENDED AT | DURATION | OWNER | TASK ERRORS
    -------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|--------------|-------|---------------------------------------------------------------------------------
    d9dea867-e945-4dde-9e92-822bb8809c12 | Synchronize capsule 'capsule.example.com' | stopped | warning | 2022/02/13 07:39:01 | 2022/02/13 08:22:06 | 00:43:04.813 | admin | Pulp task error, Pulp task error, Could not lookup a publication_href for rep...
    708f46c6-bf6d-4e5e-9306-d83dfb777616 | Synchronize capsule 'capsule.example.com' | stopped | warning | 2022/02/13 07:07:00 | 2022/02/13 07:29:16 | 00:22:16.181 | admin | Connection refused - connect(2) for 10.74.195.193:443 (Errno::ECONNREFUSED), ...
    388f349e-1a75-47cd-9800-318462f5ebb4 | Sync Content View on Capsule(s) | stopped | warning | 2022/02/13 07:07:00 | 2022/02/13 07:29:16 | 00:22:16.599 | admin | A sub task failed
    8e2e1498-dddd-4b5d-9154-95a9225d581e | Synchronize capsule 'capsule.example.com' | stopped | warning | 2022/02/13 07:07:00 | 2022/02/13 07:29:16 | 00:22:16.721 | admin | Connection refused - connect(2) for 10.74.195.193:443 (Errno::ECONNREFUSED), ...
    de63799f-fa46-4f77-8588-ae85b80f04a2 | Sync Content View on Capsule(s) | stopped | warning | 2022/02/13 07:06:59 | 2022/02/13 07:29:16 | 00:22:17.064 | admin | A sub task failed
    -------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|--------------|-------|---------------------------------------------------------------------------------

At this stage even if i visit this page Satellite UI --> Infrastructure --> Capsules --> <Click open Capsule> , the error pops up.

And now I clear up those tasks:

  1. foreman-rake foreman_tasks:cleanup TASK_SEARCH='label ~ Capsule and result != success' STATES='stopped' VERBOSE=true
    About to remove 5 tasks matching filter
    0/5
    5/5
    Deleted 5 tasks matching filter
    No orphaned task locks found, skipping.
    About to remove 3 orphaned task links
    0/3
    3/3
    Deleted 3 orphaned task links
    No orphaned execution plans found, skipping.
    No orphaned job invocations found, skipping.

And the issue is no longer present

Expected results:

Show such errors only when actually a communication issue is present but not by referring to the status of the last failed capsule synced task (which may have experienced some connection issue at that point).

Additional info:

NA

Associated revisions

Revision 2a19fa75 (diff)
Added by Justin Sherrill 3 months ago

Fixes #34671 - clarify sync error on smart proxy sync

Revision 8ee24ae7 (diff)
Added by Samir Jha about 2 months ago

Refs #34671 - clarify sync error on smart proxy sync (#10099)

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10030 added

#2 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.5.0 added

#3 Updated by Justin Sherrill 3 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Ryan Verdile 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.5.0
  • Subject changed from UI suddenly shows "Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors" for a capsule even if there are no connectivity issue present in Satellite\Capsule 7.0 to UI suddenly shows "Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors" for a capsule even if there are no connectivity issue present

#5 Updated by Ryan Verdile 3 months ago

  • Subject changed from UI suddenly shows "Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors" for a capsule even if there are no connectivity issue present to UI suddenly shows "Connection refused - connect(2) for 10.74.xxx.yyy:443 (Errno::ECONNREFUSED) Plus 6 more errors" for a smart proxy even if there are no connectivity issue present

#6 Updated by The Foreman Bot about 2 months ago

  • Pull request https://github.com/Katello/katello/pull/10099 added

#7 Updated by The Foreman Bot 24 days ago

  • Pull request https://github.com/Katello/katello/pull/10152 added

Also available in: Atom PDF