Project

General

Profile

Bug #34681

Updates oauth Gem installed by puppet-agent-oauth under Debian to a newer version (0.5.1 produces lots of warnings about URI.escape)

Added by Andreas Ntaflos 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Debian/Ubuntu
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Under Debian/Ubuntu the .deb package puppet-agent-oauth installs the oauth Gem in Puppet's Ruby environment by means of a post-install hook into /opt/puppetlabs/puppet/lib/ruby/gems/2.7.0/gems/oauth-0.5.1.

This version of oauth is old and produces annoying warnings (about 100 lines) under Puppet 7 during every Puppet agent run on any node that runs foreman-proxy:

/opt/puppetlabs/puppet/lib/ruby/gems/2.7.0/gems/oauth-0.5.1/lib/oauth/helper.rb:12: warning: URI.escape is obsolete
/opt/puppetlabs/puppet/lib/ruby/gems/2.7.0/gems/oauth-0.5.1/lib/oauth/helper.rb:12: warning: URI.escape is obsolete
/opt/puppetlabs/puppet/lib/ruby/gems/2.7.0/gems/oauth-0.5.1/lib/oauth/helper.rb:12: warning: URI.escape is obsolete
/opt/puppetlabs/puppet/lib/ruby/gems/2.7.0/gems/oauth-0.5.1/lib/oauth/helper.rb:12: warning: URI.escape is obsolete
...

I see that under RedHat the oauth Gem is installed in a newer version (0.5.5) that should not produce any warnings related to URI.escape so it seems to me that there is no reason to keep the oauth Gem at 0.5.1 under Debian.

I can provide a PR that does the work of updating oauth to 0.5.5 but I am not 100% on the Foreman project's packaging workflows.

Associated revisions

Revision d1ed7df0 (diff)
Added by Andreas Ntaflos 3 months ago

Fixes #34681 - Update puppet-agent-oauth to 0.5.5

History

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/7745 added

#3 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.3.0 added

#4 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Triaged changed from No to Yes
  • Category set to Debian/Ubuntu
  • Fixed in Releases 3.1.3, 3.2.1 added

#5 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by Amit Upadhye about 2 months ago

  • Subject changed from Should update oauth Gem installed by puppet-agent-oauth under Debian to a newer version (0.5.1 produces lots of warnings about URI.escape) to Updates oauth Gem installed by puppet-agent-oauth under Debian to a newer version (0.5.1 produces lots of warnings about URI.escape)

Also available in: Atom PDF