Project

General

Profile

Bug #34717

The foreman-protector plugin does not works for Satellite 7.0 if the OS is RHEL 8

Added by Amit Upadhye 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2058844

Description of problem:

The foreman-protector plugin does not works for Satellite 7.0 if the OS is RHEL 8 but works fine on the RHEL 7 OS.

Version-Release number of selected component (if applicable):

satellite-7.0.0-0.5.beta.el8sat.noarch
rubygem-foreman_maintain-1.0.3-1.el8sat.noarc

How reproducible:

Always

Steps to Reproduce:
1. Install RHEL 8
2. Install Satellite 7.0 on top of RHEL 8
3. Run dnf install or dnf repolist commands and observe the different in the outputs\behaviors compared to a RHEL 7 based installation.

Actual results:

On Sat 7.0 + RHEL 7, We see correct output:

  1. yum list tmux
    Loaded plugins: foreman-protector, product-id, search-disabled-repos, subscription-manager

WARNING: Excluding 12903 packages due to foreman-protector.
Use foreman-maintain packages install/update <package>
to safely install packages without restrictions.
Use foreman-maintain upgrade run for full upgrade.

Error: No matching Packages to list

  1. yum search tmux --disableplugin=foreman-protector
    Loaded plugins: product-id, search-disabled-repos, subscription-manager

===================================================================================== N/S matched: tmux ======================================================================================
tmux.x86_64 : A terminal multiplexer

Name and summary matches only, use "search all" for everything.
[root@saydas-rhsat ~]# yum list tmux --disableplugin=foreman-protector
Loaded plugins: product-id, search-disabled-repos, subscription-manager

This system is not registered with an entitlement server. You can use subscription-manager to register.

Available Packages
tmux.x86_64

But the plugin is not even recognized on RHEL 8:

  1. foreman-maintain packages status
    Running preparation steps required to run the next scenarios ================================================================================
    Check if tooling for package locking is installed: [OK]
    --------------------------------------------------------------------------------

Running detection of status of package version locking ================================================================================
Check status of version locking of packages:
Automatic locking of package versions is enabled in installer.
Packages are locked. [OK]
--------------------------------------------------------------------------------

  1. dnf list tmux --enableplugin=foreman-protector
    No matches found for the following enable plugin patterns: foreman-protector
    Updating Subscription Management repositories.
    Satellite Utils 7.0 RHEL8 1.2 kB/s | 2.1 kB 00:01
    Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 1.3 kB/s | 2.4 kB 00:01
    Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 1.5 kB/s | 2.8 kB 00:01
    Satellite 7.0 RHEL8 1.4 kB/s | 2.5 kB 00:01
    Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPMs) 1.3 kB/s | 2.3 kB 00:01
    Satellite Maintenance 7.0 RHEL8 1.1 kB/s | 2.1 kB 00:01
    Available Packages
    tmux.x86_64 2.7-1.el8 rhel-8-for-x86_64-baseos-rpms
  1. dnf repolist -v
    Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, groups-manager, kpatch, needs-restarting, playground, product-id, repoclosure, repodiff, repograph, repomanage, reposync, subscription-manager, uploadprofile
    Updating Subscription Management repositories.
    DNF version: 4.7.0
    cachedir: /var/cache/dnf
  1. dnf install tmux
    Updating Subscription Management repositories.
    Satellite Utils 7.0 RHEL8 1.1 kB/s | 2.1 kB 00:01
    Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs) 1.3 kB/s | 2.4 kB 00:01
    Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 1.5 kB/s | 2.8 kB 00:01
    Satellite 7.0 RHEL8 1.4 kB/s | 2.5 kB 00:01
    Red Hat Ansible Engine 2 for RHEL 8 x86_64 (RPMs) 1.3 kB/s | 2.3 kB 00:01
    Satellite Maintenance 7.0 RHEL8 1.1 kB/s | 2.1 kB 00:01
    Dependencies resolved. ==============================================================================================================================================================================================
    Package Architecture Version Repository Size ==============================================================================================================================================================================================
    Installing:
    tmux x86_64 2.7-1.el8 rhel-8-for-x86_64-baseos-rpms 317 k

Transaction Summary ==============================================================================================================================================================================================
Install 1 Package

Total download size: 317 k
Installed size: 770 k
Is this ok [y/N]: y
Downloading Packages:
tmux-2.7-1.el8.x86_64.rpm 0% [ ] --- B/s | 0 B --:-- ETA

Expected results:

The foreman-protector is an important plugin to ensure that accidental installation or updates are not happening on satellite and hence it needs to work with dnf+RHEL8 in the exact same way as it works with yum on RHEL 7.

Additional info:

NA


Related issues

Related to Packaging - Bug #34801: Update the foreman-protector's Yum and Dnf source file pathsClosed

Associated revisions

Revision 450fa4b5 (diff)
Added by Amit Upadhye 4 months ago

Fixes #34717 - The foreman-protector plugin for the dnf

Revision f421367a (diff)
Added by Amit Upadhye 4 months ago

Refs #34717 - don't manage version locking files from foreman-maintain

The foreman-maintain use to copy config, source files of
foreman-protector yum plugin. This change handles it using
reinstall of foreman-maintain package which puts the files in
correct location if those are missing.

Revision 8a08fa6b (diff)
Added by Amit Upadhye 4 months ago

Refs #34717 - remove unreferenced procedure to enable version locking

History

#1 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_maintain/pull/593 added

#2 Updated by Amit Upadhye 4 months ago

  • Status changed from Ready For Testing to Closed

#3 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/605 added

#4 Updated by Amit Upadhye 4 months ago

  • Related to Bug #34801: Update the foreman-protector's Yum and Dnf source file paths added

#5 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/607 added

Also available in: Atom PDF