Project

General

Profile

Bug #34819

Puppet Agent enabled in Katello installations, even if it should not

Added by Evgeni Golov 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Ohai,

Katello deployments default to Puppet disabled these days, but for some reason a freshly deployed system still has the puppet.service enabled and started, resulting in errors in the logs:

Apr 26 07:18:53 centos8-stream-katello-4-4.tanso.example.com systemd[1]: Started Puppet agent.
Apr 26 07:18:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Connection to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed, trying next route: Request to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed after 0.0 seconds: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:18:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Wrapped exception:
Apr 26 07:18:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:18:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: No more routes to ca
Apr 26 07:20:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Connection to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed, trying next route: Request to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed after 0.001 seconds: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:20:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Wrapped exception:
Apr 26 07:20:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:20:54 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: No more routes to ca
Apr 26 07:22:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Connection to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed, trying next route: Request to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed after 0.001 seconds: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:22:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Wrapped exception:
Apr 26 07:22:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:22:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: No more routes to ca
Apr 26 07:24:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Connection to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed, trying next route: Request to https://centos8-stream-katello-4-4.tanso.example.com:8140/puppet-ca/v1 failed after 0.001 seconds: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:24:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Wrapped exception:
Apr 26 07:24:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: Failed to open TCP connection to centos8-stream-katello-4-4.tanso.example.com:8140 (Connection refused - connect(2) for "centos8-stream-katello-4-4.tanso.example.com" port 8140)
Apr 26 07:24:55 centos8-stream-katello-4-4.tanso.example.com puppet-agent[41442]: No more routes to ca
…

I think the issue is the $puppet = true in https://github.com/theforeman/puppet-foreman_proxy_content/blob/413896789684ca48012a78e63ca014fd73e5d26c/manifests/init.pp#L98
as that leads to the inclusion of the puppet class down the road: https://github.com/theforeman/puppet-foreman_proxy_content/blob/413896789684ca48012a78e63ca014fd73e5d26c/manifests/init.pp#L369-L380

Associated revisions

Revision 2c81622c (diff)
Added by Evgeni Golov 2 months ago

Fixes #34819 - disable Puppet by default

We don't enable Puppet in the Katello scenario by default, but having it
true here still pulls in the Agent, which then can't connect anywhere.

History

#2 Updated by The Foreman Bot 2 months ago

  • Assignee set to Evgeni Golov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy_content/pull/415 added

#3 Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 3.3.0 added

#4 Updated by Evgeni Golov 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF