Project

General

Profile

Bug #34830

Submit button on Edit page of a host will revert back to a invalid page on Foreman

Added by Oleh Fedorenko 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Inventory
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2054011

Description of problem:

- Clicking the submit option on the Host Edit page reverts to an invalid host page.

Version-Release number of selected component (if applicable):

- satellite-7.0.0-0.5.beta.el7sat.noarch
- foreman-3.1.1.4-1.el7sat.noarch

How reproducible:

- Always

Steps to Reproduce:

1. Register a host to the Satellite

2. Access the client on the UI

Satellite WebUI: Hosts --> All Hosts --> Select the Host --> Edit

3. Make any change in the page and click Submit or simply click Submit button

Actual results:

- The action reverts to any invalid host page.

- The domain seems to be added to the hostname of the host again.

- The URL is generated as such.

https://satellite.example.com/new/hosts/client.example.com.example.com#/Overview

Expected results:

- The submit action should revert back to the host page successfully.

Associated revisions

Revision 3bc478f4 (diff)
Added by Oleh Fedorenko about 2 months ago

Fixes #34830 - Construct hostname for redirect each time

History

#1 Updated by Oleh Fedorenko 2 months ago

  • Status changed from New to Assigned

#2 Updated by The Foreman Bot 2 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9201 added

#3 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 3.3.0 added

#4 Updated by Oleh Fedorenko about 2 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Amit Upadhye about 2 months ago

  • Subject changed from Submit button on Edit page of a host will revert back to a invalid page on Satellite to Submit button on Edit page of a host will revert back to a invalid page on Foreman

Also available in: Atom PDF