Project

General

Profile

Bug #34882

Pulp: Add options to change the import and export path in /etc/pulp/settings.py

Added by William Clark about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2028446

Description of problem:

[RFE] Add options to change the import and export path in /etc/pulp/settings.py

Version-Release number of selected component (if applicable):
satellite-6.10

How reproducible:
New installation

Actual results:

There is no option available through custom-hiera.yaml or satellite-installer to change the below directories to custom path

  1. cat /etc/pulp/settings.py

ALLOWED_IMPORT_PATHS = ["/var/lib/pulp/sync_imports", "/var/lib/pulp/imports"]
ALLOWED_EXPORT_PATHS = ["/var/lib/pulp/exports"]

It seems to be a hard-coded in the configuration :

  1. cat /usr/share/foreman-installer/modules/foreman_proxy_content/manifests/init.pp |grep -iE "sync_imports|imports"
    $pulpcore_allowed_import_path = ['/var/lib/pulp/sync_imports']
    $pulpcore_allowed_import_path = ['/var/lib/pulp/sync_imports', '/var/lib/pulp/imports']
  1. cat /usr/share/foreman-installer/modules/pulpcore/templates/settings.py.erb

ALLOWED_IMPORT_PATHS = <%= scope['pulpcore::allowed_import_path'] %>
ALLOWED_EXPORT_PATHS = <%= scope['pulpcore::allowed_export_path'] %>

Expected results:

If changing the import and export path is allowed, then we will need a module for custom-hiera.yaml and satellite-installer parameter

Additional info:

Tried the below parameters in hiera but not work after running the installer.

  1. cat /etc/foreman-installer/custom-hiera.yaml

pulpcore::allowed_import_path: ['/mnt/test5', '/mnt/test6']
pulpcore::allowed_export_path: ['/mnt/test7']

Associated revisions

Revision c8ba0fe5 (diff)
Added by William Clark about 2 months ago

Fixes #34882 - allow custom pulpcore import/export paths

History

#1 Updated by The Foreman Bot about 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-foreman_proxy_content/pull/417 added

#2 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases 3.3.0 added

#3 Updated by William Clark about 2 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF