Project

General

Profile

Bug #34896

satellite-change-hostname on capsule runs deprecated capsule-installer

Added by Evgeni Golov about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2084106

Description of problem:
satellite-change-hostname on capsule runs deprecated capsule-installer

Version-Release number of selected component (if applicable):
6.11.0 Snap19
satellite-common-6.11.0-0.11.beta.el7sat.noarch
katello-common-4.3.0-1.el7sat.noarch

How reproducible:
deterministic

Steps to Reproduce:
1.Run satellite-change-hostname on capsule

  1. satellite-change-hostname new-sat.example.com -u admin -p changeme -c /root/new-sat.example.com-certs.tar -y
    Checking for certs tarball

Checking hostname validity
updating hostname in /etc/hostname
setting hostname
checking if hostname was changed
stopping services
removing old cert rpms
No Match for argument: sat.example.com-apache*
No Match for argument: sat.example.com-foreman-client*
No Match for argument: sat.example.com-foreman-proxy*
No Match for argument: sat.example.com-foreman-proxy-client*
No Match for argument: sat.example.com-puppet-client*
No Match for argument: sat.example.com-qpid-broker*
No Match for argument: sat.example.com-qpid-client-cert*
No Match for argument: sat.example.com-qpid-router-client*
No Match for argument: sat.example.com-qpid-router-server*
No Match for argument: sat.example.com-tomcat*
deleting old certs
backed up /var/www/html/pub to /var/www/html/pub/sat.example.com-20220511061913.backup
updating hostname in /etc/hosts
updating hostname in foreman installer scenarios
backing up last_scenario.yaml
removing last_scenario.yaml
re-running the installer
capsule-installer --scenario capsule -v --disable-system-checks --foreman-proxy-register-in-foreman false --certs-tar-file /root/new-sat.example.com-certs.tar
restoring last_scenario.yaml
cleaning up temporary files
ERROR: capsule-installer is no longer used. Please use 'satellite-installer --scenario capsule'.
For more information on available options, include '--help'.

Something went wrong with the Capsule installer.
Please check the above output and the corresponding logs.
Once the issue is resolved you may complete the hostname change by running: 'capsule-installer --scenario capsule -v --disable-system-checks'
and completing the following steps:
You will have to update the Name and URL of the Smart Proxy in Capsule to the new hostname.

Failed 'capsule-installer --scenario capsule -v --disable-system-checks --foreman-proxy-register-in-foreman false --certs-tar-file /root/new-sat.example.com-certs.tar' with exit code 1

Actual results:
tool doesn't work on capsule (capsule-installer was on 6.1)

Expected results:
tool works on capsule successfully

Additional info:
/usr/sbin/katello-change-hostname:15: proxy_hyphenated: "foreman-proxy-content",
/usr/sbin/satellite-change-hostname:15: proxy_hyphenated: "capsule",

/usr/share/katello/hostname-change.rb:36:
def get_default_program
case @last_scenario
when "katello"
return "foreman"
when @proxy_hyphenated
return "foreman" <- this is expected
else
return @last_scenario <- this is actual result
end
end

  1. ll /etc/foreman-installer/scenarios.d/last_scenario.yaml
    lrwxrwxrwx. 1 root root 47 May 11 08:02 /etc/foreman-installer/scenarios.d/last_scenario.yaml -> /etc/foreman-installer/scenarios.d/capsule.yaml

capsule-installer is tried as default_program = capsule and script then runs {@options[:program]}-installer

Associated revisions

Revision 0bf35df0 (diff)
Added by Evgeni Golov about 1 month ago

Fixes #34896 - properly detect default_program in k-c-h

`get_default_program` needs `@proxy_hyphenated` to be properly defined
to work, so it needs to be called after the option parse block

History

#1 Updated by The Foreman Bot about 2 months ago

  • Assignee set to Evgeni Golov
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/7888 added

#2 Updated by Ian Ballou about 2 months ago

  • Subject changed from satellite-change-hostname on capsule runs deprecated capsule-installer to satellite-change-hostname on capsule runs deprecated capsule-installer
  • Project changed from Katello to Packaging

Moving to packaging since the PR is packaging-only.

#3 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases 3.4.0 added

#4 Updated by Evgeni Golov about 1 month ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF