Project

General

Profile

Bug #34902

Un-break Katello after Foreman settings change

Added by Jeremy Lenz about 2 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

apparently when https://github.com/theforeman/foreman/pull/9050 is merged, this will break Katello for reasons I don't fully understand yet

we need to test Katello and figure out how to un-break it

Ondrej Ezr, 6:32 AM
hi! 🙂I've got bad news, PR that is about to be merged will break Katello _ https://github.com/theforeman/foreman/pull/9050

It happened to foreman as well and it was fixed in https://github.com/theforeman/foreman/pull/9155
so the root cause is that some weird AR subclass is initialized before some well behaved class (the well behaved first class was always Setting, but it will no longer be true)

Ondrej Ezr, 10:12 AM
so what I did was put pp caller on top of <foreman>/app/models/application_record.rb, figured that first time it gets required is from Facet, so I've postponed facet registration and all worked well again

so my educated guess would be you will need to move https://github.com/Katello/katello/blob/2a10b1eb15f0dab79630aeba832b67b8ef043767/lib/katello/plugin.rb#L291 into a [in_to_prepare](https://github.com/theforeman/foreman/blob/8e0e3f78fb69789cacc29888bc121a541134269c/app/registries/foreman/plugin.rb#L481)

History

#1 Updated by Jeremy Lenz about 2 months ago

  • Description updated (diff)

#2 Updated by Ian Ballou about 2 months ago

  • Triaged changed from No to Yes

#3 Updated by Jeremy Lenz about 2 months ago

  • Status changed from New to Rejected

turns out it was a foreman-tasks issue

see https://projects.theforeman.org/issues/34917

Also available in: Atom PDF