Project

General

Profile

Bug #34933

Web elements are not localized Available Button

Added by Chris Roberts about 2 months ago. Updated 25 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Created attachment 1715166 [details]
Non localized strings on web element.

Created attachment 1715166 [details]
Non localized strings on web element.

Description of problem: In locale ja_JP, zh_CN, pt_BR, fr_FR, and es_ES, Text on web element are not translated as per locale.

Version-Release number of selected component (if applicable):Satellite 6.8.0 Beta

How reproducible: Always

Steps to Reproduce:
1. Login to Satellite 6.8 instance with any locale.
2. Navigate to Content - Red Hat Repositories.
3. Look for 'Available' drop down, 'Search' button, 'ON/OFF' switch button.

Actual results: Strings are not marked as translatable strings.

Expected results: Strings should be marked as translatable strings.

Additional info: Please see attached screen shot.

Associated revisions

Revision 4c0e4933 (diff)
Added by Chris Roberts about 2 months ago

Fixes #34933 - Add translate to search dropdown on rh repo page (#10118)

History

#1 Updated by Chris Roberts about 2 months ago

I looked into this more and here is what I found:

  • Search button has been translated properly:

See screenshot attached to bz

  • On/Off Toggle:

It looks like Patternfly 3 does not support labels for states: https://github.com/patternfly/patternfly-react/blob/patternfly-3/packages/patternfly-react/src/components/Switch/Switch.js

I do see Pattenfly 4 does, so until this page gets revamped to P4 then the on/off selector will not translate.

https://www.patternfly.org/2020.04/documentation/react/components/switch

I did try the props but it didn't do anything

  • Dropdown:

I did see a few spots missing the translate bits, so will make a pr for that.

#2 Updated by The Foreman Bot about 2 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10118 added

#3 Updated by Chris Roberts about 2 months ago

  • Subject changed from Web elements are not localized (Available Button to Web elements are not localized Available Button

#4 Updated by The Foreman Bot about 2 months ago

  • Fixed in Releases Katello 4.5.0 added

#5 Updated by Chris Roberts about 2 months ago

  • Difficulty set to easy
  • Status changed from Ready For Testing to Closed

#6 Updated by Lucy Fu about 2 months ago

  • Triaged changed from No to Yes
  • Target version changed from Katello Next to Katello 4.5.0

#7 Updated by The Foreman Bot 25 days ago

  • Pull request https://github.com/Katello/katello/pull/10152 added

Also available in: Atom PDF