Project

General

Profile

Actions

Bug #34996

closed

Smart Proxy upgrade/install fails due to proxy configuration in 'HTTP(S) proxy' in settings

Added by Adam Ruzicka about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Smart Proxy
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1984400

Description of problem:

If we have a proxy set in Administer -> Settings -> General -> 'HTTP proxy' then capsule installation/upgrade fails because Satellite is not able to connect to capsule through proxy. In this scenario, the solution is to either remove the proxy or add the capsule in 'HTTP proxy except hosts' list.

Version-Release number of selected component (if applicable):
Satellite 6.x

How reproducible:
Always

Steps to Reproduce:
1. Set the proxy in Administer -> Settings -> General -> 'HTTP proxy'
2. Proxy should not be configured for internal routing
3. Try installing or upgrade the existing capsule.

Actual results:
Installation or upgrade fails.

Expected results:

We should add the capsule FQDN in 'HTTP proxy except hosts' automatically at the time of certificate generation on the Satellite or in some other way to prevent such issues.

Additional info:

Actions #1

Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9245 added
Actions #2

Updated by The Foreman Bot about 2 years ago

  • Fixed in Releases 3.4.0 added
Actions #3

Updated by Anonymous about 2 years ago

  • Status changed from Ready For Testing to Closed
Actions #4

Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Subject changed from Capsule upgrade/install fails due to proxy configuration in 'HTTP(S) proxy' in settings to Smart Proxy upgrade/install fails due to proxy configuration in 'HTTP(S) proxy' in settings
Actions #5

Updated by The Foreman Bot almost 2 years ago

  • Fixed in Releases 3.3.1 added
Actions

Also available in: Atom PDF