Project

General

Profile

Actions

Bug #35015

closed

Scheduled job "Create RSS notifications" does not use proxy

Added by Adam Ruzicka about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Notifications
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1892752

Description of problem:

Satellite without direct access to internet is unable to get rss notifications because the job ignores any proxy configurations.

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. Configure a default proxy on Satellite
2. Configure http_proxy

~~~
  1. hammer settings set --name http_proxy --value http://myproxy:3128
    ~~~
    3. Wait for the next execution and monitor the network traffic.
    Optionally, run the task manually:

~~
foreman-rake rss:create_notifications
~~

Actual results:
Foreman tries to go directly to the URL configured, ignoring proxy.

Expected results:
Foreman should use one of the defined proxies.

Additional info:


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #35014: Extension to inject global http proxy into net/http requests does not set the proxy correctlyClosedAdam RuzickaActions
Actions

Also available in: Atom PDF