Project

General

Profile

Bug #35148

[Upgrade Pulp Deb] pulp-deb fails to sync repo with a package that contains + in the name

Added by Rossen G 5 months ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Tooling
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Repo in question: https://packages.confluent.io/clients/deb

Error when attempting to sync:

404, message='Not Found', url=URL('https://packages.confluent.io/clients/deb/pool/main/c/confluent-libserdes/confluent-libserdes++1_8.0.0-1.cflt~ubu20_amd64.deb')

The error is caused by + not being encoded as %2B when making the request for the package. I've tested the repo in apt, and it works. Tested with curl too:

$ curl -I 'https://packages.confluent.io/clients/deb/pool/main/c/confluent-libserdes/confluent-libserdes++1_8.0.0-1.cflt~ubu20_amd64.deb'
HTTP/1.1 404 Not Found
Content-Type: application/xml
Connection: keep-alive
Date: Thu, 30 Jun 2022 15:28:04 GMT
Server: AmazonS3
X-Cache: Error from cloudfront
Via: 1.1 b92a7362e458b7339c38e84d8768135e.cloudfront.net (CloudFront)
X-Amz-Cf-Pop: MAN50-C3
Age: 7

$ curl -I 'https://packages.confluent.io/clients/deb/pool/main/c/confluent-libserdes/confluent-libserdes%2B%2B1_8.0.0-1.cflt~ubu20_amd64.deb'
HTTP/1.1 200 OK
Content-Type: application/x-debian-package
Content-Length: 17604
Connection: keep-alive
Date: Thu, 30 Jun 2022 15:28:20 GMT
Last-Modified: Fri, 24 Jun 2022 23:48:11 GMT
ETag: "48f1c14a12193754eb3ae198992e362e" 
Accept-Ranges: bytes
Server: AmazonS3
X-Cache: Miss from cloudfront
Via: 1.1 b5e57b301d7ec04bd5d65f7619eb0f34.cloudfront.net (CloudFront)
X-Amz-Cf-Pop: MAN50-C3

History

#1 Updated by Lucy Fu 5 months ago

Please open the issue to https://github.com/pulp/pulp_deb.

#2 Updated by Quirin Pamp 5 months ago

This has now been fixed on the pulp_deb main, 2.18, 2.17, and 2.16 branches.
Once one of those branches is released, and packaged for Katello, it will be fixed in Katello as well. :/

#3 Updated by Partha Aji 5 months ago

Need to Upgrade pulp debian to 4.5 Katello

#4 Updated by Partha Aji 5 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.5.1
  • Category set to Tooling

#5 Updated by Partha Aji 5 months ago

  • Subject changed from pulp-deb fails to sync repo with a package that contains + in the name to [Upgrade Pulp Deb] pulp-deb fails to sync repo with a package that contains + in the name

#7 Updated by Ian Ballou 2 months ago

  • Target version changed from Katello 4.5.1 to Katello 4.7.0

I'm moving this up to 4.7.0 because I have yet to see the issue released in any pulp_deb version besides 2.19.1. We'll be using that version for Katello 4.7.

https://docs.pulpproject.org/pulp_deb/changes.html#id2

#8 Updated by Ian Ballou 2 months ago

  • Target version changed from Katello 4.7.0 to Katello 4.6.1

Actually, I'll bump it down to 4.6 and request that a new version of pulp_deb 2.18 get released. Looks like that would be 2.18.1.

#9 Updated by Samir Jha 4 days ago

  • Target version changed from Katello 4.6.1 to Katello 4.7.0
  • Assignee set to Samir Jha
  • Status changed from New to Resolved

Moving off of 4.6.1 to 4.7 as it's resolved in that version.

Also available in: Atom PDF