Project

General

Profile

Bug #3534

CI failure on 1.8.7: mime-types 2.0 requires Ruby 1.9 or above

Added by Dominic Cleal almost 5 years ago. Updated 3 months ago.

Status:
Closed
Priority:
High
Category:
Hammer core
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

http://ci.theforeman.org/job/test_hammer_cli/32/ruby=1.8.7/console

Installing mime-types (2.0) 
Gem::InstallError: mime-types requires Ruby version >= 1.9.2.
An error occurred while installing mime-types (2.0), and Bundler cannot
continue.

Associated revisions

Revision 4ca98de1 (diff)
Added by Tomas Strachota almost 5 years ago

fixes #3534 - mime-types require ruby >= 1.9.2 since 2.0

mime-types version pinned < 2.0 for ruby 1.8.7

Revision 8ea97e29 (diff)
Added by Tomas Strachota almost 5 years ago

fixes #3534 - mime-types require ruby >= 1.9.2 since 2.0

mime-types version pinned < 2.0 for ruby 1.8.7

Revision b474506f
Added by Dominic Cleal almost 5 years ago

Merge pull request #37 from tstrachota/mime

fixes #3534 - mime-types require ruby >= 1.9.2 since 2.0

Revision f35926e8
Added by Dominic Cleal almost 5 years ago

Merge pull request #47 from tstrachota/mime

fixes #3534 - mime-types require ruby >= 1.9.2 since 2.0

History

#1 Updated by Tomáš Strachota almost 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomáš Strachota

#2 Updated by Tomáš Strachota almost 5 years ago

  • Status changed from Assigned to Ready For Testing

Both hammer_cli and hammer_cli_foreman have mime-types in the dependency tree.

https://github.com/theforeman/hammer-cli-foreman/pull/37
https://github.com/theforeman/hammer-cli/pull/47

#3 Updated by Tomáš Strachota almost 5 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF