Project

General

Profile

Bug #35369

Incremental export on repository exports not working correctly after syncably exporting repository

Added by Partha Aji 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Inter Server Sync
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem

Exporting a repository or library in a syncable format causes a new version to publish before completely exporting the version. This means the next time you do a "non-syncable" incremental export of the same repository, the incremental export happens from the syncable version to the latest which is incorrect. Ideally the syncable and non-syncable exports are not mixed.

Version-Release number of selected component (if applicable): 4.5 / 4.6

How reproducible:
Always

Steps to Reproduce:
1. Create and sync a repository
2. hammer content-export complete repository --id=<repo-id>
3. Now add extra rpms to the source repo and resync
4. hammer content-export complete repository --id=<repo-id> --format=syncable
5. Finally run -> hammer content-export incremental repository --id=<repo-id>

Actual results:
The incremental export has no content. This is because its trying to incrementally export from Step 4 -> 5 instead of Step 1 - 3

Expected results:
It incrementally exports between the repo on step 1 vs the repo in step 3

Additional info:

Associated revisions

Revision 7195abf6 (diff)
Added by Partha Aji 3 months ago

Fixes #35369 - Moved the syncable repo exports to a different cv (#10237)

Whenever we do an export repository or library we would
1) Find or Create the associated repo/library cv
2) Publish the version
3) Export the published version in a syncable format

With the addition of syncable format we do the same.
This has some unintended consequences
For example
1) Export the repository in an importable format
2) Update the repository contents
3) Now export the same repo in syncable format
4) Finally do an incremental export of the same repo
Notice that it has 0 content to export. That is because it is
incrementally exporting between the repo state in 3 and 4 instead of 1
and 4

This commit fixes this by making the syncable exports happen in an
entirely different content view, so that syncable and non syncable
exports are not mixed.

History

#1 Updated by Partha Aji 4 months ago

  • Bugzilla link set to 2118431

#2 Updated by The Foreman Bot 4 months ago

  • Assignee set to Partha Aji
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10237 added

#3 Updated by Chris Roberts 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.6.0

#4 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.7.0 added

#5 Updated by Partha Aji 3 months ago

  • Status changed from Ready For Testing to Closed

#6 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/Katello/katello/pull/10255 added

Also available in: Atom PDF