Project

General

Profile

Refactor #35429

Update oauth to version 1

Added by Ewoud Kohl van Wijngaarden 3 months ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Category:
Packaging
Target version:
-
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Currently we're using version 0.6.1 but version 1.0.0 is out. It is backwards incompatible because it dropped Ruby < 2.7 support, but that doesn't affect Foreman.

Associated revisions

Revision 2991d552 (diff)
Added by Ewoud Kohl van Wijngaarden 3 months ago

Refs #35429 - Update rubygem-oauth to 1.0.0

Revision 61347251 (diff)
Added by Ewoud Kohl van Wijngaarden 3 months ago

Fixes #35429 - Update oauth to version 1.x

It is backwards incompatible because it dropped Ruby < 2.7 support, but
that doesn't affect Foreman.

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9379 added

#2 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/9380 added

#3 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/9380)

#4 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/8396 added

#5 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases 3.5.0 added

#6 Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Ewoud Kohl van Wijngaarden 1 day ago

  • Triaged changed from No to Yes

Also available in: Atom PDF