Project

General

Profile

Bug #35459

Non-enabled repository types make it into the apipie help-text

Added by Ian Ballou 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2043126

Description of problem:
Non-enabled repository types make it into the apipie help-text, such as "deb" or "python".

Version-Release number of selected component (if applicable):
Katello 4.2+

How reproducible:
Always.

Steps to Reproduce:
1. hammer repository create --help

Actual results:
--content-type ENUM Type of repo
Possible value(s): 'ansible_collection', 'deb', 'docker', 'file', 'ostree',
'python', 'yum'

Expected results:
Don't include types not supported by the smart proxy.

Additional info:
The issue is due to how the apipie cache is generated statically. Since it's not generated with a running Foreman, we cannot use the enabled repository types.

For a medium-term fix, we could remove the repo types completely from the apipie definition and add in an endpoint to check the enabled content types.

For a longer-term fix, we could switch to having the apipie cache generating dynamically in Foreman. That will require more consideration.

Associated revisions

Revision b9069a44 (diff)
Added by Ian Ballou 3 months ago

Refs #35459 - create hammer command to show repository types (#864)

Revision 71959b72 (diff)
Added by Ian Ballou 3 months ago

Fixes #35459 - Non-enabled repository types make it into the apipie help-text (#10259)

History

#1 Updated by Ian Ballou 3 months ago

  • Subject changed from Non-enabled repository types make it into the apipie help-text to Non-enabled repository types make it into the apipie help-text

API is GET /katello/api/repositories/repository_types

#2 Updated by Ian Ballou 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.7.0

#3 Updated by The Foreman Bot 3 months ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10259 added

#4 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/864 added

#5 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.7.0 added

#6 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF