Project

General

Profile

Bug #35484

Unable to apply all Errata via Remote Execution on Web UI with "Select All"

Added by Ian Ballou 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2115767

Description of problem:

When trying to apply all errata using Errata installation via remote execution, the errata filed getting blank on job invocation page.

Version-Release number of selected component (if applicable):

Katello 4.3+, maybe 4.2.

How reproducible:

Steps to Reproduce:
1.Navigate to Hosts -> Content Hosts
2.Click host on which errata need to be applied
3.Click on Errata installation
4.Now we will get count of 20 errata per-page. Select all errata in one go using "All # items on this page are selected. Select all #"
5.Apply errata via remote execution

Actual results:

Now we will faced the actual issue the job invocation page shows the errata field as blank. So basically no errata can be applied.

Expected results:

Should be able to use select all to select all errata and apply them successfully via remote execution

Additional info:

If we increase the count of Entry per page from 20 to something higher so that we can see all errata in one page, then errata application via remote execution is working while using "select all".

It seems the same issue was fixed in bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1846670 but it was reported again on 4.3.

Associated revisions

Revision 04a4cbc1 (diff)
Added by Ian Ballou 3 months ago

Fixes #35484 - Unable to apply all Errata via Remote Execution on Web UI with "Select All" (#10262)

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Ian Ballou
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10262 added

#2 Updated by Jeremy Lenz 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.7.0
  • Subject changed from Unable to apply all Errata via Remote Execution on Web UI with "Select All" to Unable to apply all Errata via Remote Execution on Web UI with "Select All"

#3 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 4.7.0 added

#4 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Ian Ballou about 1 month ago

  • Target version changed from Katello 4.7.0 to Katello 4.6.1

Moving this one back since it's kinda an annoying bug. Has a quick fix though.

Also available in: Atom PDF