Project

General

Profile

Feature #35496

Add default pulp_deb config during installer runs

Added by Quirin Pamp 3 months ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman modules
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Users syncing from partial Ubuntu mirrors (a common scenario) currently get an error.

The solution is to add `FORCE_IGNORE_MISSING_PACKAGE_INDICES = True` to `/etc/pulp/settings.py`.
This should be done by default for all Katello installations with pulp_deb.

Associated revisions

Revision 5e2bfd7e (diff)
Added by Quirin Pamp about 1 month ago

Fixes #35496 - Add default pulp_deb config

https://projects.theforeman.org/issues/35496

For Katello users this is the sane/expected default behaviour. It allows
for the synchronization of partial Ubuntu mirrors, a very common use
case in the wild. Users often stumble over the error that is thrown for
such mirrors without this setting.

History

#1 Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-pulpcore/pull/263 added

#2 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases 3.5.0 added

#3 Updated by Quirin Pamp about 1 month ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Ewoud Kohl van Wijngaarden 1 day ago

  • Triaged changed from No to Yes
  • Category set to Foreman modules

Also available in: Atom PDF