Project

General

Profile

Feature #35510

Explicitly depend on webrick for Ruby 3 support

Added by Ewoud Kohl van Wijngaarden 3 months ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Category:
Packaging
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

In Ruby 3 webrick is no longer included and is now a regular gem.

Associated revisions

Revision a921761d (diff)
Added by Ewoud Kohl van Wijngaarden about 1 month ago

Fixes #35510 - Depend on webrick for Ruby 3

This has always been a dependency, but Ruby 3 has dropped the code. It's
now a regular gem.

It is set in the gemspec since that allows plugins to also benefit from
it. That does mean that it's also required on older Ruby versions and
should be packaged.

History

#1 Updated by The Foreman Bot 3 months ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/846 added

#2 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases 3.5.0 added

#3 Updated by Ewoud Kohl van Wijngaarden about 1 month ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Ewoud Kohl van Wijngaarden 1 day ago

  • Triaged changed from No to Yes

Also available in: Atom PDF