Project

General

Profile

Actions

Bug #35604

closed

Repository sets not reflecting SCA status on direct load

Added by Partha Aji over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

This is related to https://projects.theforeman.org/issues/35596

If I directly go http://centos8-katello-devel-stable.example.com/new/hosts/&lt;hostname&gt;#/Content/Repository%20sets instead of going via All Hosts > <hostname>> Content->Repository Sets the sca status is not reflected correctly.

Steps:
  1. Ensure Org has simple content access
  2. Create a Custom repository
  3. Register a host
  4. Go to host => manage statuses
  5. Remove the subscription status
  6. Now go to the repository sets page and copy the url
  7. Make sure you are able to see repo sets
  8. log off
  9. log back in
  10. directly go to the reposets url

Expected:
Reposets displayed

Actual:
No Reposets.

Actions #1

Updated by Partha Aji over 1 year ago

  • Target version set to Katello 4.7.0
  • Triaged changed from No to Yes
Actions #2

Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 4.7.0 to Katello 4.8.0
Actions #3

Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lucy Fu
  • Pull request https://github.com/Katello/katello/pull/10345 added
Actions #4

Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.8.0 added
Actions #5

Updated by Lucy Fu over 1 year ago

  • Status changed from Ready For Testing to Closed
Actions #6

Updated by Jeremy Lenz about 1 year ago

  • Bugzilla link set to 2188287
Actions

Also available in: Atom PDF