Project

General

Profile

Bug #35610

Content view filter will include module streams of other repos/arches if the errata contain rpms in multiple repos/arches.

Added by Hao Yu about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:
As per subject.

Steps to Reproduce:
1. Enable and sync RHEL 8 Baseos and Appstream x86_64 repos
2. Create a content view and add both repos
3. Create the following filters.

Include errata until end date = 26/07/2022
Include all module streams without errata
Include all packages without errata

4. Publish the content view. The results should have the following number of module streams.

593 Module streams

5. Enable and sync RHEL 8 Baseos and Appstream ppcle64 repos. Wait until the sync finish.

6. Publish new version of the content view.

Actual results:
Module streams count almost doubled up as below. Clicks into the module streams link you will see many ppcle64 module streams in the content view.

1094 Module streams

Expected results:
Module streams count remain 593

Additional info:
Same issue in Satellite 6.10

This is because Katello uses "api.repositories_api.modify(repository_href, add_content_units: content_unit_href)" API in the Pulp3 to copy contents. This API can copy any contents without specifying the source repository.

Satellite 6.9.9 doesn't have this issue because Katello uses the copy API in pulp 2 to copy units from source repo to destination repos. Thus, units not in the source repo can't be copied.

Associated revisions

Revision 3cff7f7c (diff)
Added by Hao Yu about 1 month ago

Fixes #35610 - CV filter copies modules not in the source repo (#10308)

History

#1 Updated by Hao Yu about 2 months ago

  • Subject changed from Content view filter will include module streams of other arches if the errata contain rpms with different arches. to Content view filter will include module streams of other repos/arches if the errata contain rpms in multiple repos/arches.

#2 Updated by The Foreman Bot about 2 months ago

  • Assignee set to Hao Yu
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10308 added

#3 Updated by Partha Aji about 2 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.7.0

#4 Updated by The Foreman Bot about 1 month ago

  • Fixed in Releases Katello 4.7.0 added

#5 Updated by Hao Yu about 1 month ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF