Project

General

Profile

Actions

Bug #35666

closed

hammer repository types command is missing options

Added by Ian Ballou over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2137350

Description of problem:
`hammer repository types` isn't including the `creatable` option that's available in the API. I believe it's because `build_options` is missing in the related class in hammer-cli-katello

Version-Release number of selected component (if applicable):
Katello 4.7+

How reproducible:
Always

Steps to Reproduce:
1. Check `hammer repository types --help

Actual results:
--creatable is not in the options

Expected results:
--creatable should be in the options

Additional info:

Actions #1

Updated by Jeremy Lenz over 1 year ago

  • Subject changed from hammer repository types command is missing options to hammer repository types command is missing options
  • Category set to Hammer
  • Target version set to Katello 4.8.0
  • Triaged changed from No to Yes
Actions #2

Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Chris Roberts
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/869 added
Actions #3

Updated by Chris Roberts over 1 year ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF