Project

General

Profile

Bug #35684

Filter "Applied catalog in x.y seconds" messages out of Puppet report

Added by Ewoud Kohl van Wijngaarden about 1 month ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Category:
Foreman modules
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

We filter out "Finished catalog run in x.y seconds" but somewhere between Puppet report format version 3 and 6 the message changed to "Applied catalog in x.y seconds". This is then stored in the DB while it's also reported as a metric. It should be filtered out again.

Associated revisions

Revision 4f65dd51 (diff)
Added by Ewoud Kohl van Wijngaarden about 1 month ago

Fixes #35684 - Drop Applied catalog lines

In the past we dropped the line which stated how log catalog application
took since there's a metric for this. This was done by matching the
content, but the content changed somewhere between report version 3 and
6.

This saves a lot of redundant messages in the Foreman database. An
uneventful report will now have no messages at all.

History

#1 Updated by The Foreman Bot about 1 month ago

  • Assignee set to Ewoud Kohl van Wijngaarden
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-puppetserver_foreman/pull/25 added

#2 Updated by Ewoud Kohl van Wijngaarden about 1 month ago

  • Triaged changed from No to Yes
  • Status changed from Ready For Testing to Closed
  • Fixed in Releases 3.5.0 added

#3 Updated by Ewoud Kohl van Wijngaarden 1 day ago

Looks like this caused a regression: if there is no log entry, Foreman can't determine the source of the report. See https://community.theforeman.org/t/identify-config-report-origin/31465 for more details.

Also available in: Atom PDF