Project

General

Profile

Actions

Bug #35746

closed

Cannot sync ansible collections repositories to smart proxy

Added by Ian Ballou over 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Ansible Collections
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

I believe the issue is here: https://github.com/Katello/katello/blob/master/app/services/katello/pulp3/repository/ansible_collection.rb#L28

My smart proxy was getting a 404 trying to find the collection tar.gz file:

Last sync failed: URL: foreman.example.com/pulp_ansible/galaxy/default/api/v3/plugin/ansible/content/Default_Organization/Precipitation/All_Repo_Types/custom/Buttermilk_Pancakes/Ansible_Repo/collections/artifacts/geerlingguy-php_roles-0.9.3.tar.gz not supported.

I could download the tar.gz file here: https://foreman.example.com/pulp/content/Default_Organization/Precipitation/All_Repo_Types/custom/Buttermilk_Pancakes/Ansible_Repo/geerlingguy-php_roles-0.9.3.tar.gz

Actions #1

Updated by Samir Jha over 1 year ago

  • Target version set to Katello 4.7.1
  • Triaged changed from No to Yes
Actions #2

Updated by Chris Roberts over 1 year ago

  • Target version changed from Katello 4.7.1 to Katello 4.8.0
Actions #3

Updated by Lucy Fu over 1 year ago

  • Target version changed from Katello 4.8.0 to Katello 4.9.0
Actions #4

Updated by Lucy Fu about 1 year ago

  • Target version changed from Katello 4.9.0 to Katello 4.10.0
Actions #5

Updated by Chris Roberts 8 months ago

  • Target version changed from Katello 4.10.0 to Katello 4.11.0
Actions #6

Updated by Ian Ballou 7 months ago

  • Status changed from New to Resolved
  • Fixed in Releases Katello 4.11.0 added

I cannot reproduce this even in Katello 4.7.

Actions

Also available in: Atom PDF