Project

General

Profile

Actions

Bug #35750

closed

hammer content-view purge only deletes up to "Entries per page" versions

Added by Chris Roberts over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
easy
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Running "hammer content-view purge --id <id>" on a content view with 1,000 versions only deletes 16 versions.

The output shows that the command only deletes up to one page of versions and ignores the rest.
Customer being forced to re-run the command multiple times and/or increase the number of "Entries per page" at Administer -> Settings -> General, which affects everything else in the Satellite.

Version-Release number of selected component (if applicable):
tfm-rubygem-hammer_cli-3.1.0.1-1.el7sat

How reproducible:
Always

Steps to Reproduce:
1. Create 100 versions of a CV
2. Run "hammer content-view purge --id <id>"
3.

Actual results:
Only 16 versions are deleted (with the default "Entries per page" value of 20).

Expected results:
97 versions are deleted regardless of the value of "Entries per page".

Additional info:
hammer should iterate through the pages and delete all versions as requested in a single execution of the command.
Nowhere in the help of the command or the Satellite documentation states that the command is limited to a single page.

Actions #1

Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/873 added
Actions #2

Updated by Samir Jha over 1 year ago

  • Triaged changed from No to Yes
Actions #3

Updated by Ian Ballou over 1 year ago

  • Status changed from Ready For Testing to Closed

Closing since the PR is merged.

Actions #4

Updated by Ian Ballou over 1 year ago

  • Fixed in Releases Katello 4.8.0 added
Actions

Also available in: Atom PDF