Project

General

Profile

Actions

Bug #35861

closed

Unable to promote content view due to "NoMethodError: undefined method `get_status' for nil:NilClass"

Added by Samir Jha over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2147579

Description of problem:

Unable to promote content view due to "NoMethodError: undefined method `get_status' for nil:NilClass"

Version-Release number of selected component (if applicable):

How reproducible:*
100%

Steps to Reproduce:

1. Publish job is working as expected using the Ansible playbook.
2. Promoting with the below playbook fails with error:-
3. Run a playbook using the module `redhat.satellite.content_view_version`
```
- name: Publish new content view version to lib and dev
redhat.satellite.content_view_version:
username: "{{ user }}"
password: "{{ pw }}"
server_url: "{{ url }}"
content_view: "{{ view }}"
organization: "{{ org }}"
validate_certs: no
description: "testing content view"
lifecycle_environments:
- Dev
loop: "{{ views }}"
loop_control:
loop_var: view
```

Actual results:
"msg": "Task Promote content view 'Test'; organization 'Test'(xxxxxx) did not succeed. Task information: [\"undefined method `get_status' for nil:NilClass\"]",

Expected results:
Success

Actions #1

Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Samir Jha
  • Pull request https://github.com/Katello/katello/pull/10391 added
Actions #2

Updated by Samir Jha over 1 year ago

  • Subject changed from Unable to promote content view due to "NoMethodError: undefined method `get_status' for nil:NilClass" to Unable to promote content view due to "NoMethodError: undefined method `get_status' for nil:NilClass"
  • Target version set to Katello 4.8.0
  • Triaged changed from No to Yes
Actions #3

Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.8.0 added
Actions #4

Updated by Samir Jha over 1 year ago

  • Status changed from Ready For Testing to Closed
Actions #5

Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/Katello/katello/pull/10421 added
Actions #6

Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/Katello/katello/pull/10430 added
Actions

Also available in: Atom PDF