Project

General

Profile

Bug #3604

IP missing from Host Output

Added by Greg Sutcliffe over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
API
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hammer attempts to list the IP in the output of "hammer host list" but because the IP isn't in the RABL, the column is empty:

$ hammer host list
---|----------------------------------|---------------------|---------------|----|----
ID | NAME | OPERATING SYSTEM ID | HOST GROUP ID | IP | MAC
---|----------------------------------|---------------------|---------------|----|----
1 | test4.elysium.emeraldreverie.org | 1 | | |
---|----------------------------------|---------------------|---------------|----|----

We should either add this to the rabl or remove the column from Hammer.

History

#1 Updated by Greg Sutcliffe over 5 years ago

  • Description updated (diff)

#2 Updated by Ohad Levy over 5 years ago

I would like to add at least IP, as its such a common thing, and does not cost anything for fetching it.

we could also consider adding attributes, such as last_compile/last_report and type?

#3 Updated by Dominic Cleal over 5 years ago

I'd think it should probably match the web UI columns?

#4 Updated by Ohad Levy over 4 years ago

  • Target version set to 1.7.5

#5 Updated by Ori Rabin over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Ori Rabin

#6 Updated by Ori Rabin over 4 years ago

  • Status changed from Assigned to Resolved

I can't reproduce this, I assume there is a duplicate bug that has been closed but I haven't found it.

Also available in: Atom PDF