Project

General

Profile

Actions

Bug #36088

closed

Setting descriptions are not translated

Added by Nofar Alfassi about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
-
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2130871

Description of problem:
In the satellite settings, there are many entries stating Foreman instead of Satellite.
The entries sometimes state Satellite in the name column but in the description column, there is Foreman (sometimes there is just Foreman in a place where I think Satellite should be). I think that this should be consistent and we should use Satellite in settings entries.

Version-Release number of selected component (if applicable):
satellite-6.12.0-3.el8sat.noarch
foreman-3.3.0.8-1.el8sat.noarch

How reproducible:
every time

Steps to Reproduce:
1. Go to satellite settings and see entries from the list below. In these entries, I think we should change Foreman to Satellite. ##############################################################
List of settings entries where I have found inconsistencies: ##############################################################
Settings>General>Satellite URL
Settings>General>Entries per page
Settings>General>Capsule request timeout
Settings>General>Append domain names to host
Settings>General>Satellite UUID
Settings>General>New host details UI

Settings>RHCloud>Include parameters in insights-client repos

Settings>Authentication>OAuth active
Settings>Authentication>OAuth map users
Settings>Authentication>Failed login attempts limit
Settings>Authentication>SSL certificate
Settings>Authentication>SSL CA file
Settings>Authentication>SSL private key
Settings>Authentication>Server CA file
Settings>Authentication>Websockets SSL key
Settings>Authentication>Websockets SSL certificate

Settings>Email>Email reply address

Settings>Provisioning>Host owner
Settings>Provisioning>Query local nameservers
Settings>Provisioning>Update IP from built request
Settings>Provisioning>Use short name for VMs
Settings>Provisioning>Clean up failed deployment
Settings>Provisioning>Destroy associated VM on host delete
Settings>Provisioning>Manage PuppetCA
Settings>Provisioning>USE UUID certificates

Settings>Facts>Create new host when fats are uploaded
Settings>Facts>Update hostgroup from facts
Settings>Facts>Update subnets from facts

Settings>Config Management>Create new host when report is uploaded
Settings>Config Management>Matchers inheritance
Settings>Config Management>Default parameters lookup path
Settings>Config Management>Interpolate ERB in parameters

Settings>Ansible>Default verbosity level
Settings>Ansible>Post-provision timeout
Settings>Ansible>Default Ansible inventory report template

Settings>Template Sync>Commit message ##############################################################

Actual results:
Foreman is stated instead of Satellite

Expected results:
Satellite should be stated instead of Foreman

Additional info:
The same problem is happening in Satellite 6.11

Actions #1

Updated by Nofar Alfassi about 1 year ago

  • Subject changed from Settings states Foreman instead of Satellite in some entries to Settings states Foreman instead of Satellite in some entries
  • Assignee set to Nofar Alfassi
Actions #2

Updated by Ewoud Kohl van Wijngaarden about 1 year ago

I think this is a downstream issue which we should solve in the branding plugin (foreman_theme_satellite). That only lives downstream so I'm not sure anything needs to be done in upstream.

That said, this may be fallout from the settings DSL change and it's no longer possible to brand those. The entries used to be stored in the DB, so you could do a migration but that may no longer possible.

Actions #3

Updated by Shimon Shtein about 1 year ago

This is an upstream issue, as it's affecting translation.
Basically the description is not translated, which we can consider a bug.

Quoting Eric here:

This appears to be an issue with how the Description column is treated when rendering the Settings tables. The Description values are not passing through the translation layer which does the replacement of keywords for branding (e.g. Foreman -> Satellite). I believe this is because the Description is using the standard cellFormatter (https://github.com/theforeman/foreman/blob/develop/webpack/assets/javascripts/react_app/components/common/table/formatters/cellFormatter.js) as seen here (https://github.com/theforeman/foreman/blob/develop/webpack/assets/javascripts/react_app/components/SettingsTable/SettingsTableSchema.js#L33). 

Somehow, either cellFormatter needs to change to call translate, i.e. {__(value)} which will apply to all uses of cellFormatter, or a custom formatter needs to be created specifically for the Settings table. As I am not as familiar with the overall ramifications of a change like this, I leave it up to whomever fixes this to decide the best course of action.

Actions #4

Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9713 added
Actions #5

Updated by The Foreman Bot 11 months ago

  • Fixed in Releases 3.7.0 added
Actions #6

Updated by Nofar Alfassi 11 months ago

  • Status changed from Ready For Testing to Closed
Actions #7

Updated by Ewoud Kohl van Wijngaarden 11 months ago

  • Subject changed from Settings states Foreman instead of Satellite in some entries to Setting descriptions are not translated
  • Category changed from Settings to Internationalization
  • Triaged changed from No to Yes

Looking at the final patch, I'm changing the subject and category. That downstream (ab)uses the translations is a side effect, but untranslated descriptions affects all users.

Actions

Also available in: Atom PDF