Project

General

Profile

Feature #3652

Add explicit way for API consumers to specifiy all pages in an index request

Added by Walden Raines almost 9 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

From: https://github.com/theforeman/theforeman.org/pull/119/files#r7659148

Currently a user must specify per_page=<some large number> in order to ensure they receive all members of a collection. We ought to allow a more explicit method of doing this such as per_page=all.


Related issues

Related to Hammer CLI - Bug #5073: [RFE] Ability to disable paginationClosed2014-04-04
Has duplicate Foreman - Feature #3868: Allow users to turn on pagination by e.g. per_page=0Duplicate2013-12-12
Blocks Hammer CLI - Feature #3898: Pagination should be turned off by default in --csv modeDuplicate2013-12-17

History

#1 Updated by Dominic Cleal almost 9 years ago

  • Has duplicate Feature #3868: Allow users to turn on pagination by e.g. per_page=0 added

#2 Updated by Dominic Cleal over 8 years ago

  • Blocks Feature #3898: Pagination should be turned off by default in --csv mode added

#3 Updated by Dominic Cleal over 8 years ago

  • Related to Bug #5073: [RFE] Ability to disable pagination added

#4 Updated by Tomáš Strachota over 7 years ago

  • Bugzilla link set to 1179096

#5 Updated by Tom Caspy over 7 years ago

  • Status changed from New to Duplicate

this is not a bug. csv output is paginated. we can't ensure returning all items, because it will fail for large lists. This ticket is a dup of #3898

Also available in: Atom PDF