Project

General

Profile

Actions

Bug #36523

closed

Optimized capsule sync doesn't sync recently published/promoted docker repositories

Added by Samir Jha 12 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Yes
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2215238

Description of problem:
If user triggers an optimized Capsule sync manually after publishing/promoting a content view containing docker repositories. The capsule sync task doesn't sync anything.

How reproducible:
Easy

Steps to Reproduce:
1. Set "Sync Capsules after content view promotion" to No
2. Create and sync a docker repository.
~~~
Registry URL: https://registry-1.docker.io/
Upstream Repository Name: library/hello-world

  1. Limit the tag to sync
    Include Tags: latest
    ~~~

3. Create a content view and attach the docker repository to it. Publish and promote the content view.
4. Trigger a optimized capsule sync to sync the CV repositories for the first time to the Capsule.
5. In the docker repository page, include a new tag and sync it.

Include Tags: latest, linux

6. Publish and promote new version of the content view.
7. Trigger a optimized capsule sync again

Actual results:
The optimized capsule sync doesn't sync newly published docker repositories

Expected results:
Optimized capsule sync should sync the newly published docker repositories.

Additional info:
This is because the smart proxy sync history of the docker repositories didn't get clear after publishing/promoting the content view.

Actions #1

Updated by Jeremy Lenz 12 months ago

  • Subject changed from Optimized capsule sync doesn't sync recently published/promoted docker repositories to Optimized capsule sync doesn't sync recently published/promoted docker repositories
  • Target version set to Katello 4.8.3
  • Triaged changed from No to Yes
Actions #2

Updated by The Foreman Bot 12 months ago

  • Status changed from New to Ready For Testing
  • Assignee set to Samir Jha
  • Pull request https://github.com/Katello/katello/pull/10629 added
Actions #3

Updated by The Foreman Bot 12 months ago

  • Fixed in Releases Katello 4.10.0 added
Actions #4

Updated by Samir Jha 12 months ago

  • Status changed from Ready For Testing to Closed
Actions #5

Updated by Ewoud Kohl van Wijngaarden 11 months ago

  • Fixed in Releases Katello 4.8.3 added
Actions #6

Updated by William Clark 9 months ago

  • Target version changed from Katello 4.8.3 to Katello 4.9.2
Actions #7

Updated by The Foreman Bot 9 months ago

  • Pull request https://github.com/Katello/katello/pull/10754 added
Actions #8

Updated by The Foreman Bot 9 months ago

  • Pull request deleted (https://github.com/Katello/katello/pull/10629, https://github.com/Katello/katello/pull/10754)
Actions #9

Updated by The Foreman Bot 9 months ago

  • Fixed in Releases Katello 4.9.2 added
Actions #10

Updated by Samir Jha 5 months ago

  • Pull request https://github.com/Katello/katello/pull/10629 added
Actions

Also available in: Atom PDF