Project

General

Profile

Actions

Bug #36599

closed

A failed "Actions::Katello::Host::Hypervisors" task lacks identifying information

Added by Chris Roberts 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Description of problem:

When a "Actions::Katello::Host::Hypervisors" task ends with error/warnings, it does not indicate any detail about what hypervisor caused the issue. With the patch attached to this RFE, the error message displays also the ID and hostname of the affected hypervisor. The customer finds this addition really useful to identify the root cause of the problem, and requests to implement it in future Red Hat Satellite releases.

Actual results:

original error message:
~~
hypervisors warning: "Validation failed: Name must not include periods; Name must not include periods"
~~

Actions #1

Updated by The Foreman Bot 11 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10654 added
Actions #2

Updated by Ian Ballou 11 months ago

  • Triaged changed from No to Yes
Actions #3

Updated by Chris Roberts 11 months ago

  • Status changed from Ready For Testing to New
  • Assignee deleted (Chris Roberts)
  • Target version changed from Katello 4.10.0 to Katello 4.11.0
  • Difficulty deleted (easy)
  • Pull request deleted (https://github.com/Katello/katello/pull/10654)
Actions #4

Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Assignee set to Chris Roberts
  • Pull request https://github.com/Katello/katello/pull/10654 added
Actions #5

Updated by The Foreman Bot 11 months ago

  • Fixed in Releases Katello 4.10.0 added
Actions #6

Updated by Chris Roberts 11 months ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF