Project

General

Profile

Actions

Bug #36617

closed

Pin minitest < 5.19 to resolve test failures

Added by Samir Jha 12 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
Target version:
-

Description

5.19.0 release of minitest causes errors with several of test gems we use. (https://github.com/minitest/minitest/issues/960)
I was able to see issues with minitest-spec-rails-6.2.0, mocha(Their latest release fixes this), shoulda-matchers-4.3.0.. I didn't go further.. We should pin minitest to 5.18.1 for now to unblock our tests.

Actions

Also available in: Atom PDF