Project

General

Profile

Actions

Bug #36639

closed

Template proxy is not used for IPv6 subnets

Added by Ewoud Kohl van Wijngaarden 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
Unattended installations
Target version:
-
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

When provisioning a host using the Smart Proxy template feature it's only used from the IPv4 subnet.

To reproduce, create a host with only an IPv6 subnet (that has a template proxy set) on the provisioning interface. You would expect the template proxy to be used, but instead you see the actual unattended URL.

It's because this only looks at subnet and not subnet6.

https://github.com/theforeman/foreman/blob/7c4128649ea125f799389eb0dec24a847e3b8416/app/services/foreman/foreman_url_renderer.rb#L66

Actions #1

Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Assignee set to Ewoud Kohl van Wijngaarden
  • Pull request https://github.com/theforeman/foreman/pull/9794 added
Actions #2

Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 3.8.0 added
Actions #3

Updated by Ewoud Kohl van Wijngaarden 4 months ago

  • Status changed from Ready For Testing to Closed
Actions #4

Updated by Ewoud Kohl van Wijngaarden 3 months ago

  • Triaged changed from No to Yes
Actions

Also available in: Atom PDF