Project

General

Profile

Actions

Bug #36741

closed

Ubuntu version "nil" is interpreted as "0"

Added by Bastian Schmidt 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Fixed in Releases:
Found in Releases:

Description

If no minor version is defined in the OS in Foreman, it is interpreted as 0.

This is especially an issue, since Ubuntu >= 20.04.3 uses a different Installation Media path and templates.

If the minor version is "nil" it should take the latest version (or no explicit .0 version).

The issue is here:
https://github.com/theforeman/foreman/blob/6a292004b525e47acd946dd59fdc13af5bb21ba5/app/models/operatingsystems/debian.rb#L84

Actions #1

Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/9831 added
Actions #2

Updated by The Foreman Bot 4 months ago

  • Fixed in Releases 3.10.0 added
Actions #3

Updated by Bastian Schmidt 4 months ago

  • Status changed from Ready For Testing to Closed
Actions #4

Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/theforeman/foreman/pull/10005 added
Actions

Also available in: Atom PDF