Project

General

Profile

Bug #3687

Kafo tests depend on Ruby 1.9.3+, but the Gemspec doesn't specify this

Added by Jon McKenzie about 9 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Running the

test
rake target on EL6 fails due to import and syntax errors. If the tests depend on 1.9.3+, this should be detected or captured somewhere (gemspec?)


Related issues

Related to Kafo - Feature #3340: Create a test infrastructureClosed2013-10-17

Associated revisions

Revision d0204eac (diff)
Added by Marek Hulán about 9 years ago

Fixes #3687 - Tests are compatible with ruby 1.8

History

#1 Updated by Marek Hulán about 9 years ago

During work on #3340 hopefully we'll setup testing on more ruby versions so we'll know what exactly is supported. I'm currently running tests on Ruby 2.0.0 and tests depends on simplecov and minitest. Later we could add some *-devel or *-test package which would install all test deps.

#2 Updated by Dominic Cleal about 9 years ago

#3 Updated by Marek Hulán about 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Marek Hulán
  • Target version set to 1.10.0

There is incompatible code on one place which can be fixed to support 1.8.

#4 Updated by Marek Hulán about 9 years ago

  • Status changed from Assigned to Closed

Fixed in https://github.com/theforeman/kafo/pull/43
Will take effect in next released version

Also available in: Atom PDF