Project

General

Profile

Actions

Bug #37064

closed

Login-Page missing background after scrolling

Added by Markus Bucher 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

How to reproduce:

  1. open foreman login-page
  2. change browser-window's size so the login-page has a scroll-bar
  3. scroll down

Expected:
Background fills visible window

Actual:
Background stops at the bottom-edge of the original view and you can "scroll out" of the background.


Files

foreman-3.9_login-page_error.png View foreman-3.9_login-page_error.png 16.1 KB Markus Bucher, 01/18/2024 07:11 PM
Actions #1

Updated by Maria Agaphontzev 3 months ago

I couldn't reproduce it, but it looks like some old css got into the page, which browser is this happening in? are there any plugins?

Actions #2

Updated by Markus Bucher 3 months ago

I see it on a freshly installed almalinux8-katello-4.11 forklift.
So installed foreman-plugins are katello, foreman-tasks and REX.

And I see it on Firefox, Chromium and Chrome.

Actions #3

Updated by Markus Bucher 3 months ago

It works on foreman-3.5, but I do not see any difference in the code. Both specify height to be 100%.
But for some reason <div id="login-page"> and <div class="login-pf"> compute the height to be the window size in px (on foreman-3.9) instead of the height of the login-form (as it is on foreman-3.5).

Actions #4

Updated by The Foreman Bot 3 months ago

  • Status changed from New to Ready For Testing
  • Assignee set to Maria Agaphontzev
  • Pull request https://github.com/theforeman/foreman/pull/10033 added
Actions #5

Updated by The Foreman Bot 2 months ago

  • Fixed in Releases 3.10.0 added
Actions #6

Updated by Maria Agaphontzev 2 months ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF